12 сообщений / 0 новое
Последнее сообщение
Pulya313
Аватар пользователя Pulya313
Не в сети
Последнее посещение: 4 года 8 месяцев назад
Регистрация: 07/04/2015 - 23:22
Code::Blocks

На минте по этой инструкции тут нормально ставился, а на open-suse не хочет. Почему? Пишет следующие: @linux-1nw1:~> sudo aptitude update
root's password:
Sorry, try again.
root's password:
Репозиторий 'google-chrome' актуален.
Репозиторий 'openSUSE-13.2-0' актуален.
Репозиторий 'openSUSE-13.2-Non-Oss' актуален.
Репозиторий 'openSUSE-13.2-Oss' актуален.
Репозиторий 'openSUSE-13.2-Update' актуален.
Репозиторий 'openSUSE-13.2-Update-Non-Oss' актуален.
Все репозитории обновлены.
@linux-1nw1:~> sudo aptitude install codeblocks codeblocks-contrib
Загрузка данных о репозиториях...
Чтение установленных пакетов...
'codeblocks' не найдено в именах пакетов. Поиск возможностей.
Не найдено поставщиков 'codeblocks'.
'codeblocks-contrib' не найдено в именах пакетов. Поиск возможностей.
Не найдено поставщиков 'codeblocks-contrib'.
Разрешение зависимостей пакетов...

Нечего выполнять.
@linux-1nw1:~> sudo aptitude install build-essential gdb subversion automake autoconf libtool libgtk2.0-dev libxmu-dev libxxf86vm-dev
Загрузка данных о репозиториях...
Чтение установленных пакетов...
Пакет 'build-essential' не найден.
'subversion' уже установлен.
Нет кандидатов на обновление 'subversion-1.8.13-2.14.1.x86_64'. Новейшая версия уже установлена.
'libtool' уже установлен.
Нет кандидатов на обновление 'libtool-2.4.2-15.2.2.x86_64'. Новейшая версия уже установлена.
'autoconf' уже установлен.
Нет кандидатов на обновление 'autoconf-2.69-10.1.2.noarch'. Новейшая версия уже установлена.
'gdb' уже установлен.
Нет кандидатов на обновление 'gdb-7.8-2.2.1.x86_64'. Новейшая версия уже установлена.
'automake' уже установлен.
Нет кандидатов на обновление 'automake-1.13.4-5.1.2.noarch'. Новейшая версия уже установлена.
'libgtk2.0-dev' не найдено в именах пакетов. Поиск возможностей.
Не найдено поставщиков 'libgtk2.0-dev'.
'libxmu-dev' не найдено в именах пакетов. Поиск возможностей.
Не найдено поставщиков 'libxmu-dev'.
'libxxf86vm-dev' не найдено в именах пакетов. Поиск возможностей.
Не найдено поставщиков 'libxxf86vm-dev'.
Разрешение зависимостей пакетов...

Нечего выполнять.
@linux-1nw1:~> sudo aptitude install libwxbase2.8-dev wx2.8-headers libwxgtk2.8-dev wx-common
Загрузка данных о репозиториях...
Чтение установленных пакетов...
'libwxbase2.8-dev' не найдено в именах пакетов. Поиск возможностей.
Не найдено поставщиков 'libwxbase2.8-dev'.
'libwxgtk2.8-dev' не найдено в именах пакетов. Поиск возможностей.
Не найдено поставщиков 'libwxgtk2.8-dev'.
'wx-common' не найдено в именах пакетов. Поиск возможностей.
Не найдено поставщиков 'wx-common'.
'wx2.8-headers' не найдено в именах пакетов. Поиск возможностей.
Не найдено поставщиков 'wx2.8-headers'.
Разрешение зависимостей пакетов...

Как установить????

Отредактировано: Pulya313 вкл 10/04/2015 - 22:14
r3d
Аватар пользователя r3d
Не в сети
Последнее посещение: 4 года 11 месяцев назад
Регистрация: 04/09/2012 - 16:52
sudo aptitude чего?? о_О

sudo aptitude
чего?? о_О

13.1 - Xfce
Pulya313
Аватар пользователя Pulya313
Не в сети
Последнее посещение: 4 года 8 месяцев назад
Регистрация: 07/04/2015 - 23:22
"Code::Blocks" прога есть

"Code::Blocks" прога есть такая посмотри на linux mint норм ставился, на open-suse не хочет! Что тут не понятного???

slawdos
Аватар пользователя slawdos
Не в сети
Последнее посещение: 2 года 6 месяцев назад
Регистрация: 13/05/2012 - 15:43
команды те что вы вводите.

команды те что вы вводите. сусе не клон дебиан, тут нужно юзать zypper а не apt-get.

oS Leap 42.1x64KDE
~ Morpheus, i know linux...

iwtke
Аватар пользователя iwtke
Не в сети
Последнее посещение: 4 года 6 месяцев назад
Регистрация: 11/04/2014 - 19:09
http://software.opensuse.org

Русскоязычное сообщество openSUSE
Правильно заданный вопрос – половина ответа.

Pulya313
Аватар пользователя Pulya313
Не в сети
Последнее посещение: 4 года 8 месяцев назад
Регистрация: 07/04/2015 - 23:22
установил выдает при запуске

установил выдает при запуске простенькой программы

Pulya313
Аватар пользователя Pulya313
Не в сети
Последнее посещение: 4 года 8 месяцев назад
Регистрация: 07/04/2015 - 23:22
люди что делать, мне по учебе


люди что делать, мне по учебе срочняк как надо!! Выручайте
Вот нашел тут, делал полный поиск gtk.h не находит такой файл, как я думаю наверное библиотеки не были загружены, только как и где их загрузить???

r3d
Аватар пользователя r3d
Не в сети
Последнее посещение: 4 года 11 месяцев назад
Регистрация: 04/09/2012 - 16:52
Pulya313, а с чего вы решили,

Pulya313, а с чего вы решили, что линуксоид = спец по сям? И если уж на то пошло, зачем нужно IDE для хелловорда?? У вас подход к вопросу совершенно неправильный, вряд ли тут кто поможет.

gtk3-devel или gtk2-devel нужно.

13.1 - Xfce
Pulya313
Аватар пользователя Pulya313
Не в сети
Последнее посещение: 4 года 8 месяцев назад
Регистрация: 07/04/2015 - 23:22
хелловорд???? это я просто

хелловорд???? это я просто для примера показал, для того что бы было видно что консоль ни чего не отображает! И в чем неправильность подхода в том, что я хочу поставить codeblocks?

r3d
Аватар пользователя r3d
Не в сети
Последнее посещение: 4 года 11 месяцев назад
Регистрация: 04/09/2012 - 16:52
Да все равно вендузятские

Да все равно вендузятские привычки - вкорячить IDE для:

по учебе срочняк как надо!

когда хватило бы продвинутого текстового редактора, коих на линуксе хватает. Ну и потом ожидаемое "ой, а чигоито оно?" Или вас так учат, что сразу среда разработки? Тогда должны были и научить с ней работать.

13.1 - Xfce
Pulya313
Аватар пользователя Pulya313
Не в сети
Последнее посещение: 4 года 8 месяцев назад
Регистрация: 07/04/2015 - 23:22
тебе тяжело помочь??? Ок,

тебе тяжело помочь??? Ок, тогда зачем форум??

iwtke
Аватар пользователя iwtke
Не в сети
Последнее посещение: 4 года 6 месяцев назад
Регистрация: 11/04/2014 - 19:09
Заканчиваем оффтоп.

Заканчиваем оффтоп.

Русскоязычное сообщество openSUSE
Правильно заданный вопрос – половина ответа.